読者です 読者をやめる 読者になる 読者になる

クズと天才は紙一重

不定期更新です。主に日々の活動記録( ・ㅂ・)و ̑̑

railsでbootstrapを導入した時にDEPRECATION WARNINGがうるさかった話

railsでbootstrapを導入する方法は

Gamfileに以下を追加する。

gem 'therubyracer'
gem 'less-rails
gem 'twitter-bootstrap-rails'

 

その後、以下コマンドを実行

rails g bootstrap:install

 

bootstrapは使えるようになるのだが、

rails sでサーバを起動した時に

DEPRECATION WARNINGがうるさいので

gem 'less-rails'のところにこれを追加する。

gem 'less-rails', git: 'https://github.com/MustafaZain/less-rails'

するとDEPRECATION WARNINGが出なくなる。

 

もし、simple_formを導入していた場合

rails generate simple_form:installをしろというエラーも出るので

simple_formを導入していたらこちらも実行する。